Login | Register


All times are UTC - 5 hours


It is currently Tue Oct 22, 2019 9:34 pm




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: Latency issues
PostPosted: Mon Apr 11, 2011 9:16 pm 

Joined: Mon Apr 11, 2011 1:24 am
Posts: 19
For some reason my latency is really high on the realms.

My FPS is fine, and when I first connect my latency is about 150. But after a couple minutes in game my latency shoots up to over 400 and stays there.

I manually pinged the server from windows command prompt and it came back @ about 150 so it's not my actual ping to the server... any idea what is going on here and how I can fix it? Because I definitely am really experiencing half a sec of delay in gameplay.


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Latency issues
PostPosted: Tue Apr 12, 2011 12:19 am 

Joined: Mon Apr 11, 2011 1:24 am
Posts: 19
Thanks defg234, I tried your suggestion and it worked like a charm!


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Latency issues
PostPosted: Tue Apr 12, 2011 1:55 am 
User avatar

Joined: Tue Sep 01, 2009 6:28 am
Posts: 169
lol at bots post.
but does this happen on all the servers you enter or just specific ones?


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Latency issues
PostPosted: Tue Apr 12, 2011 3:08 am 

Joined: Mon Apr 11, 2011 1:24 am
Posts: 19
2 of them. I don't think I have entered all of them.

I changed from direct3d to directdraw and that helped. But it still seems higher than it should be a lot of the time. Maybe its just the servers.


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Latency issues
PostPosted: Tue Apr 12, 2011 1:48 pm 
User avatar

Joined: Fri Dec 24, 2010 6:10 am
Posts: 345
Location: Vancouver, BC
I could be other programs taking over the resources. To fix this in windows you can go to process explorer and set priority to high. It could also be a throttling issue from your service provider if you're running other programs that stream bandwidth.


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Latency issues
PostPosted: Tue Apr 12, 2011 7:24 pm 

Joined: Mon Jan 11, 2010 10:45 am
Posts: 977
i tried setting d2 to high priority and my mouse speed went slow to hell


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Latency issues
PostPosted: Wed Apr 13, 2011 2:06 am 
User avatar

Joined: Thu Jan 14, 2010 6:02 pm
Posts: 1627
Diablo ran ok on p3 cpu so it's pointless to set high priority if you have anything modern. Just set it to lower priority that it doesn't eat all resources. High priority makes sense in modern applications that have rather high cpu usage - Diablo has low but it always run 100% of a core/thread.


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Latency issues
PostPosted: Wed Apr 13, 2011 6:50 am 

Joined: Wed Jan 27, 2010 5:52 pm
Posts: 164
Location: the Netherlands
The ping in the /fps isn't accurate because it's updated on your screen after you've received the pong. (the program should start counting once the ping is on it's way and not wait for the result)

Both ZeroLag (lol?) servers are virtually unplayable, for me at least. Last Sunday I had pings from 500ms to 2500ms, but this could also be the result from someone DDOS'ing which I read somewhere, but that post was quickly hidden.

Earliest warning system I can think of is watching your merc and monsters on the screen. If they start running but stay in the same place, a big spike will be shown in the /fps numbers some time later.


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Latency issues
PostPosted: Wed Apr 13, 2011 10:38 am 
User avatar

Joined: Tue Sep 01, 2009 9:01 pm
Posts: 1392
Not to hijack, but i have seen several folks say they have issues with zerolag servers. I am not one of them. i almost always get great results from them. The european servers are a bit iffy from my side of the pond, but that is expected.

_________________
The reader should not be discouraged if...he does not have the prerequisites to read the prerequisites. P. Halmos


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Latency issues
PostPosted: Wed Apr 13, 2011 4:10 pm 
User avatar

Joined: Fri Dec 24, 2010 6:10 am
Posts: 345
Location: Vancouver, BC
Steel wrote:
Diablo ran ok on p3 cpu so it's pointless to set high priority if you have anything modern. Just set it to lower priority that it doesn't eat all resources. High priority makes sense in modern applications that have rather high cpu usage - Diablo has low but it always run 100% of a core/thread.


So the priority only sets performance of the processor it doesn't effect the network card and bandwidth?


Top
 Offline Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron