Gates of Arimyth
http://forum.arimyth.com/

Wierd problem
http://forum.arimyth.com/viewtopic.php?f=9&t=4631
Page 1 of 1

Author:  windeyak [ Mon Sep 19, 2011 8:59 pm ]
Post subject:  Wierd problem

So i installed HU and the high res pack, not the D2SE, i was playing and got the wierd colors, white dots here and theres, colors just messed in general.

Ran glide in the d2 vid test thingy, but now when i start d2 in full mode it only shows a zoomed in left top corner, but in window mode its all good, but this is super annoying, any way to fix this with full mode? if you have any idea what I mean, or i can take a picture.

Author:  Baerk [ Mon Sep 19, 2011 9:09 pm ]
Post subject:  Re: Wierd problem

Posting a screenshot to show the graphical errors would always be helpful (because then you don't have to use to words to try to describe it fully since the screenshot speaks for itself in full detail).

I've seen messed colors some times before in my experience. It's a glitch from a RAM artifact as far as I know (can't really do anything to prevent it really). As for the screwball full screen display... I got a nagging suspicion that the glide settings set in the glide-init.exe are fubared in some way and need adjusted to fix that problem.

Author:  windeyak [ Mon Sep 19, 2011 9:20 pm ]
Post subject:  Re: Wierd problem

k well the img i added is how it looks in full mode and window mode, window mode now since i changed setting on glide.! any help would be awesome

Attachments:
Untitled.jpg
Untitled.jpg [ 920.53 KiB | Viewed 2575 times ]

Author:  Baerk [ Mon Sep 19, 2011 9:38 pm ]
Post subject:  Re: Wierd problem

At first I thought it was odd that only full screen mode was messed up, but apparently your windowed mode is messed up too. Judging from what looks wrong the static size option under the settings menu in glide-init.exe is probably set wrong. The selection for that should be no instead of a resolution so that the window can change size as necessary depending on the resolution you pick.

Author:  windeyak [ Mon Sep 19, 2011 9:48 pm ]
Post subject:  Re: Wierd problem

it was set to no, so i dont know, tried changing it to 1280 X 920 or w/e it is, and that didnt help at all

Author:  Baerk [ Mon Sep 19, 2011 10:13 pm ]
Post subject:  Re: Wierd problem

While I have seen a number of strange graphical bugs from improperly switching between normal and high res I haven't seen anything like that yet. The high res plug in has clearly activated yet something's limiting the size of your screen.

There's a couple possibilities. I just noticed your screen is being limited to 640 x 480 resolution. There's a checkbox under the compatibility tab of the properties screen (reached via right clicking and selecting properties of the d2 shortcut) that can specifically force that resolution. I also managed to reproduce it being strangled down to that resolution as a glitch... The one time I managed to move my windowed mode D2 around before it reached the bnet log on screen it caused it to shrink down to 640 x 480 resolution. Do you let the d2 window be till it reaches the bnet log on screen?

Author:  windeyak [ Tue Sep 20, 2011 7:34 pm ]
Post subject:  Re: Wierd problem

I don't touch it at all, i let it sit, i had the resolution checked on the d2 shortcut in properties, i tried it with it unchecked, and still the exact same problem, could it maybe be the setting in my d2 video? in game that is.

Author:  Baerk [ Tue Sep 20, 2011 8:08 pm ]
Post subject:  Re: Wierd problem

If that particular resolution box in the properties has really stayed unchecked since the unchecking I honestly don't know what else further to suggest for this mess since I have no way of reproducing this unusual previously unheard of bug without it being a glitch caused by doing certain things during the startup.

All I can suggest at this point is a fresh install, extract a core download into it, extract either a r2 non lite or an r3 lite mpq into it, try running it and hope things work properly. And if the HU gateway isn't available then just simply run the HU registry file.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/