Login | Register


All times are UTC - 5 hours


It is currently Sun Dec 09, 2018 11:06 pm




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: need help with new patch
PostPosted: Sat Sep 17, 2011 10:33 am 
User avatar

Joined: Sat Sep 05, 2009 6:20 am
Posts: 121
I done a clean install got core and low res installed and get this message


Halt
Location : Fog\src\Mem\mem.cpp, line#902
Expression : MEMORY ERROR : out of memory


any ideas??


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: need help with new patch
PostPosted: Sat Sep 17, 2011 12:32 pm 
User avatar

Joined: Tue Sep 01, 2009 12:55 pm
Posts: 22
Location: U.K.
Having finally got my install sorted out and managed to create a character to play, I now find that I'm getting the same error message that you are when I attempt to create or join a game.

Hope someone can offer a suggestion.


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: need help with new patch
PostPosted: Sat Sep 17, 2011 3:16 pm 
User avatar

Joined: Sat Sep 05, 2009 6:20 am
Posts: 121
anyone have any ideas??


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: need help with new patch
PostPosted: Sat Sep 17, 2011 5:25 pm 
Moderator
User avatar

Joined: Mon Nov 09, 2009 3:09 pm
Posts: 815
I just found out about the source the error myself. It turns out the instructions I received on how to create a lite patch were wrong. The resulting sound related txt file modifications created something guaranteed to crash. The only reason it did not crash on me during my quick crash testing phase was because a certain command line argument I was using at the time of the test was completely suppressing the crash error.

Add the -ns command line argument to your d2 shortcut. It completely disables sound on D2. As a result it suppresses all sound related errors like the error mentioned in this thread.


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: need help with new patch
PostPosted: Sat Sep 17, 2011 7:52 pm 
User avatar

Joined: Sat Sep 05, 2009 6:20 am
Posts: 121
Baerk wrote:
I just found out about the source the error myself. It turns out the instructions I received on how to create a lite patch were wrong. The resulting sound related txt file modifications created something guaranteed to crash. The only reason it did not crash on me during my quick crash testing phase was because a certain command line argument I was using at the time of the test was completely suppressing the crash error.

Add the -ns command line argument to your d2 shortcut. It completely disables sound on D2. As a result it suppresses all sound related errors like the error mentioned in this thread.



TY TY TY :mrgreen:
Any chance of getting it fixed?
kinda sucks with no sound but guess better than not playin


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: need help with new patch
PostPosted: Mon Sep 19, 2011 11:31 am 
User avatar

Joined: Mon Aug 31, 2009 9:26 am
Posts: 490
Location: Richmond Va
Baerk wrote:
It turns out the instructions I received on how to create a lite patch were wrong. The resulting sound related txt file modifications created something guaranteed to crash.


Downloading the full version will fix this then?

_________________
I was never more at home than I was in battle. - Solomon Kane


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: need help with new patch
PostPosted: Mon Sep 19, 2011 2:51 pm 
Moderator
User avatar

Joined: Mon Nov 09, 2009 3:09 pm
Posts: 815
The new r3 lite version has the error fixed since I used the proper sound related txt file edits for it. I test ran the new r3 lite mpqs without -ns -direct -txt without any troubles on my end. As long as you don't let something like a data folder linger a new lite patch download will fix it (the data folder downloads out there are NOT configured for lite patches and will likely cause problems).


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: need help with new patch
PostPosted: Wed Sep 21, 2011 2:57 pm 
User avatar

Joined: Sat Sep 05, 2009 6:20 am
Posts: 121
Baerk wrote:
The new r3 lite version has the error fixed since I used the proper sound related txt file edits for it. I test ran the new r3 lite mpqs without -ns -direct -txt without any troubles on my end. As long as you don't let something like a data folder linger a new lite patch download will fix it (the data folder downloads out there are NOT configured for lite patches and will likely cause problems).



It works fine now much thnx for the work fixing it. :mrgreen: :mrgreen: :mrgreen:


Top
 Offline Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: