Gates of Arimyth

HU has suddenly stopped
Page 1 of 1

Author:  thebold [ Sat Sep 22, 2018 6:07 am ]
Post subject:  HU has suddenly stopped

Hi Chaps,

I have come across recently a very strange phenomenon regarding my HU and its sudden ceasing to work, lets go through many things I have tried over the days:

Firstly the D2SE mod from Ensley 1.9 upgraded to 2.1 runs; however if i try and turn on another client the BNET IP will not be available and I can not run multiple accounts.. So sad face there, however I have never used D2SE for the record in my decade?! now of playing the mod :)

So What happens for non D2SE..

A few days ago HU stoped working all the sudden (A windows Update perhaps? what could cause it to fail?); so I started changing settings and so forth what I have been through is the following:

1) Complete reinstall of LOD from base CD upgraded to 1.10.

2) After install and upgrade to 1.10 install the glide gfx driver for Windows 10 and run the tests; boot diablo in normal mode and confirm its working.. and all is working as expected, the game.exe and Diablo 2.exe both in WinXP SP3 compatibility with admin mode forced on.

3) Download the Hi Res 2.1 latest HU build, copy the files into the Diablo directory as normal and run the install, then running Diablo II.exe causes the little egg timer and then nothing further; uninstalling of HU mod can allow Diablo 2.exe to run the game back in normal mode and other times (such as now) to completely crash and die.. until i go through the entire reinstall process again..

When I run the game I notice that the bncache.dat file is not created, a BnetLog.txt file is created (which is empty) and the usual Diablo txt file to say what happened during loading or crash file is reporting not much with:

USER Realm startup at 2018-09-22 11:54:04.960
11:54:04.960 ------------------------------------------------------

Some things I would love to confirm with you chaps is the following:

My Diablo 2.exe is the same as Soulmancers ancient post using the No CD thing and that has for ever worked (working with vanilla LOD).

My game.exe reads a file size of:
C:\Diablo II>ls -la | grep Game.exe
-rwxr-xr-x 1 USER 197608 1198857 Oct 13 2003 Game.exe

This is also set to SP3 WINXP, Admin mode too (just in case?)

An assumption I am making: I don't think this is a windows issue as the game runs without HU mod installed with both versions using Glide.

Does anyone know or could suggest anything I could look into? This is all most a harder puzzle to work out then the real game it self :D

A possible thing to consider? Could it be that 2.1 was originally installed over a recently HU copy and it does not work from a complete fresh install of LOD? (making a assumption), I also attempted to download 2.0 and run with that and again nope!.

Could it by my game.exe is wrong some how? or does someone have a full NON d2se working 2.1 client i can download from someone?

Author:  thebold [ Sat Sep 22, 2018 7:17 am ]
Post subject:  Re: HU has suddenly stopped

After asking Kannli to send me his game.exe file and reinstalled HUMod install file; I can confirm the game is once again running as normal however this is most odd because:

C:\Diablo II>ls -la | grep Game.exe
-rwxr-xr-x 1 USER 197608 1198857 Sep 22 12:52 Game.exe
-rwxr-xr-x 1 USER 197608 1198857 Oct 13 2003 Game.exe.old

Anyone have any thoughts on how 2 seemingly identical files can be this way?

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group