Login | Register


All times are UTC - 5 hours


It is currently Mon Sep 24, 2018 11:13 am




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: Help installing HU 1.10
PostPosted: Tue Oct 25, 2016 7:15 pm 

Joined: Tue Oct 25, 2016 7:12 pm
Posts: 9
Hello friends --- I invested a lot of my childhood into D2 and really enjoy the game. I recently came across this new mod and I'd like to try it out but...

When I download D2/D2LoD from the Battle.net launcher they automatically install to patch 1.14b. How could i be able to revert down to 1.10 to get this mod working??

Any help would be much appreciated ^_^


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Help installing HU 1.10
PostPosted: Tue Oct 25, 2016 7:53 pm 
User avatar

Joined: Mon Aug 31, 2009 11:28 am
Posts: 1109
Location: Vancouver, BC
On online search found this promising result:
https://www.reddit.com/r/Diablo/comments/uij35/i_have_a_legal_version_of_diablo_2_lod_and_it/

In that thread they mention upgrading to v1.11, so probably started at a version early enough for you to go to v1.10.

If that doesn't work, then consider using D2SE. That program allows a variety of Vanilla D2 versions to be run, so you'd just have to configure it to run HU with v1.10.


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Help installing HU 1.10
PostPosted: Tue Oct 25, 2016 8:21 pm 

Joined: Tue Oct 25, 2016 7:12 pm
Posts: 9
Brevan wrote:
On online search found this promising result:

In that thread they mention upgrading to v1.11, so probably started at a version early enough for you to go to v1.10.

If that doesn't work, then consider using D2SE. That program allows a variety of Vanilla D2 versions to be run, so you'd just have to configure it to run HU with v1.10.


After I attempt this fix it tells me the game disc can't be found .. man this is super frustrating.

After looking up D2SE it looks like even more work and headaches.. I can't find anywhere to simply download the base game without any patches and from the Blizzard site it installs 1.14b directly -_-..


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Help installing HU 1.10
PostPosted: Tue Oct 25, 2016 10:44 pm 

Joined: Tue Sep 01, 2009 10:23 pm
Posts: 79
I downloaded D2/Lod from the bnet website and used it with d2se no problem. Maybe try that a bit more.


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Help installing HU 1.10
PostPosted: Wed Oct 26, 2016 1:22 am 

Joined: Tue Oct 25, 2016 7:12 pm
Posts: 9
e;


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Help installing HU 1.10
PostPosted: Wed Oct 26, 2016 5:46 pm 
User avatar

Joined: Tue Sep 01, 2009 9:01 pm
Posts: 1378
The direct download link in General Discussion makes all your problems go away.
viewtopic.php?f=8&t=14003

There use to be a good patch downgrader, but the link I had seems to be dead.

_________________
The reader should not be discouraged if...he does not have the prerequisites to read the prerequisites. P. Halmos


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Help installing HU 1.10
PostPosted: Sun Oct 30, 2016 2:15 pm 

Joined: Tue Oct 25, 2016 7:12 pm
Posts: 9
kramuti wrote:
The direct download link in General Discussion makes all your problems go away.
http://forum.arimyth.com/viewtopic.php?f=8&t=14003

There use to be a good patch downgrader, but the link I had seems to be dead.


Yea all of the links are frozen sadly.. that seems like exactly what I'd want.. I've tried following the instructions both with/without D2SE and end up having issues. Without using D2SE, after installing the games from Bnet I'm on patch 1.14b and every "downgrader" I've tried doesn't actually downgrade the patch, or when It does I get "Please insert the D2 LOD disc into the CD drive etc etc"

I guess my best bet is to just give up until the links are working again or unless there is another source floating around.

Kinda makes me sad but oh well.. maybe I'm just awful at getting these kids of things to work :(

locryan wrote:
I downloaded D2/Lod from the bnet website and used it with d2se no problem. Maybe try that a bit more.

I don't understand how you are able to do this.. Yes D2SE gives me the option to run D2 in 1.10, but don't I have to run the "Hell Unleashed" mod and start the pluggin? That means the base game has to be 1.10 right? Since I'm not actually using D2SE for running 1.10, only to launch the Mod itself


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Help installing HU 1.10
PostPosted: Sun Oct 30, 2016 2:47 pm 
User avatar

Joined: Mon Aug 31, 2009 11:28 am
Posts: 1109
Location: Vancouver, BC
When D2SE is up and running, within your Diablo2 installation folder will be a "Mods" folder, and within that folder you would create a "HellUnleashed" folder that contains not only the files for whatever HU version you'd like to play, but critically it contains the file "D2SE_SETUP.ini" that contains information that tells D2SE how to get the mod up and going.

You can edit the .ini file in a simple text editor like Notepad. When a line of the file starts with '#', then that line is just a comment from the D2SE creator to you, explaining how to configure the next lines.

There is a section about a quarter of the way down the file that tells D2SE which version of D2_LoD (which D2Core) to use, so in that section should be the line "D2Core=1.10f"

There is a section about half way down the file that tells D2SE which ModSystem to use for that mod. Since HU is based on D2_LoDv1.10f, it uses the D2MOD system, so in that section should be the line "ModUseD2Mod=1".

There might be other lines specific to D2v1.10f, but I didn't notice them after a quick glance.

Most link options provided for an HU download have a D2SE option where D2SE_SETUP.ini has already been configured, so you shouldn't have to edit it.


Top
 Offline Profile  
Reply with quote  
 Post subject: Re: Help installing HU 1.10
PostPosted: Sun Oct 30, 2016 3:43 pm 

Joined: Tue Oct 25, 2016 7:12 pm
Posts: 9
Brevan wrote:
When D2SE is up and running, within your Diablo2 installation folder will be a "Mods" folder, and within that folder you would create a "HellUnleashed" folder that contains not only the files for whatever HU version you'd like to play, but critically it contains the file "D2SE_SETUP.ini" that contains information that tells D2SE how to get the mod up and going.

You can edit the .ini file in a simple text editor like Notepad. When a line of the file starts with '#', then that line is just a comment from the D2SE creator to you, explaining how to configure the next lines.

There is a section about a quarter of the way down the file that tells D2SE which version of D2_LoD (which D2Core) to use, so in that section should be the line "D2Core=1.10f"

There is a section about half way down the file that tells D2SE which ModSystem to use for that mod. Since HU is based on D2_LoDv1.10f, it uses the D2MOD system, so in that section should be the line "ModUseD2Mod=1".

There might be other lines specific to D2v1.10f, but I didn't notice them after a quick glance.

Most link options provided for an HU download have a D2SE option where D2SE_SETUP.ini has already been configured, so you shouldn't have to edit it.


Alright, I feel like I am very close to solving this now, I followed everything exactly, the ini file was already edited like you said, however
Now when I click on "Start Pluggin" or just double click Hell Unleashed nothing happens and D2SE just exits.. Not sure what the issue could be :(.. this is the screen I'm looking at right before I click start plugin
http://imgur.com/a/fs6Ja

e; I'm using the 1.6c Core

I also used the files Ensley03 gave in this post -> http://forum.arimyth.com/viewtopic.php?f=8&t=14003&start=50

Overwrote those files in Plugy/dropped the D2 patch in the MOD/Hell Unleased/1.6 folder as well as the other files to replace those in the 1.6 folder --- then i arrive at my situation above - no response to clicking "Start Plugin"

e; I changed D2SE to run in Compatibility Win Xp SP3 --- Now when I launch I get D:\Diablo II\d2data.mpq is corrupt
but.. ive literally never even touched the file.. its the original file from the Battle.net download/install


Top
 Offline Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: